West and South Weatherford
Incident Report for Linxus Internet
Resolved
Service has been restored
Posted Feb 15, 2021 - 12:25 CST
Investigating
We are currently experiencing outages in the South Weatherford area. This issue may cause service disruptions and will impact Internet and VoIP customers. We are currently working to resolve this issue as quickly as possible.


Thank you for your patience.
Posted Feb 15, 2021 - 09:29 CST