Currently investingating reports of no internet in Tolar.
Incident Report for Linxus Internet
Resolved
This issue was identified and resolved.
Posted Mar 13, 2020 - 11:53 CDT
Investigating
We are currently investigating this issue.
Posted Mar 13, 2020 - 11:48 CDT
This incident affected: Tolar Hub.