VOIP / Phone Outage
Incident Report for Linxus Internet
Resolved
This incident has been resolved.
Posted Dec 17, 2021 - 18:13 CST
Investigating
Customers are reporting that VoIP / Phone service is down.
Our carrier is aware of the issue and working to get phone services restored.
Posted Dec 17, 2021 - 09:31 CST
This incident affected: VoIP Servers.