Our fiber provider is working to restore service within the hour
Posted Mar 17, 2026 - 10:24 CDT
Investigating
We are currently experiencing a service outage due to an issue with our upstream fiber provider. Our team is actively working to resolve the problem as quickly as possible. We appreciate your patience and will provide updates as they become available.
Posted Mar 17, 2026 - 09:59 CDT
This incident affected: Aledo Hub, Annetta Hub, Granbury Hub, Mineral Wells Hub, Peaster Hub, Tolar Hub, Weatherford Hub, Willow Park Hub, Website, Customer Portal, and VoIP Servers.