Investigating Outage
Incident Report for Linxus Internet
Resolved
All services have been restored
Posted Oct 28, 2021 - 13:57 CDT
Investigating
Areas include Peaster, Springtown and surrounding.
Posted Oct 28, 2021 - 13:34 CDT
This incident affected: Peaster Hub.