Customer in Aledo / Willow Park reporting no internet
Incident Report for Linxus Internet
Resolved
This incident has been resolved.
Posted Dec 06, 2020 - 15:43 CST
Investigating
We are currently investigating this issue.
Posted Dec 06, 2020 - 15:33 CST
This incident affected: Aledo Hub, Annetta Hub, and Willow Park Hub.